Ваш браузер не поддерживается

Подобная проблема может возникнуть на некоторых сайтах, аккаунтах разных систем, при использовании клиент-банка и т.п.

 Ваш браузер не поддерживается

Недавно при работе с google adsense войдя в аккаунт увидел сообщение Ваш браузер не поддерживается и тут же редирект на мобильную версию, видимо произошло это в связи с введением нового интерфейса аккаунта. Ранее всегда пользовался браузером опера, то ли привык уже то ли удобно, но менять браузер ой как не хочется, а работать надо.

Теперь немного информации о принципе работы браузеров, а точнее о юзер-агенте, что такое user-agent, для чего он нужен и как используется читаем в wki. А в кратце: любая система или вебсайт узнают ваш браузер именно по юзер-агенту, и если браузер (по мнению разработчиков сайта или приложения) не удовлетворяет условиям или требованиям, то получает отказ в обслуживании. В моем случае отображалась не полная, а мобильная версия adsense, что очень не удобно.

Такие же приемы (по сугубо моему личному мнению) используются для устранения конкурентов в гонке за лидерство браузеров. Так гугл продвигает свой продукт хром притесняя оперу, но это все лирика. Перейдем к решению проблемы.

Включить поддержку java

Заходим на проблемный сайт или в нужный аккаунт, перехеодим на вкладку Инструменты —  быстрые настройки — настройки для сайта.

ваш браузер не поддерживается

Или вместо тыков в меню жмем клавишу F12

В разделе скрипты проверяем включена ли поддержка java в опере, если нет то действуем по инструкции как включить java в опере. Без этого у вас не будут работать функции и апплеты написанные на java, а это и браузерные игры, и приложения клиент-банк и многое ругое.

включить java в опере

 

Как имзенить user-agent в браузере опера

теперь последний шаг

На вкладке сеть в селекторе (см. скриншот) — идентификация браузера выбираем Представляться как Firefox или Представляться как Internet Explorer.

как изменить user-agent в опере

Теперь проблемные сайты и приложения, для которых вы включили использование другого юзер-агента, будут считать что вы зашли через браузер IE или FF, а не через оперу.

изменить user-agent в FireFox

Если вы получили сообщение Ваш браузер не поддерживается в FireFox, поступаем как и в предыдущем случае, но немного другим путем. Здесь для замены юзер-агента применяются плагины, пример показан на плагине User Agent Switcher.

Для начала настроим браузер FireFox для более удобной работы. Жмем на рыжую кнопку, в открывшейся навигации переходим в настройки — панель меню.

как настроить firefox

Теперь в верхней части браузера вы видите полное меню навигации.

жмем Инструменты — Дополнения 

или нажимаем сочетание клавиш Ctrl+Shift+A

поиск дополнений для firefox

перешли на стрницу плагинов, справа в поисковой форме вводим запрос и получаем список подходящих плагинов, среди них видим User Agent Switcher, хотя вы можете использовать и другой.

поиск плагинов для firefox

Устанавливаем плагин, и теперь во вкладке инструменты видим новую строчку Default user Agent, здесь и выбираем нужный нам.

Для браузеров Internet Explorer и Google Срromе изменить юзер-агент… с заморочками, но можно, но не вижу смысла т.к. для них как правило никаких ограничений мафия разработчиков не вводит? у них все работает и везде браузер поддерживается 🙂